cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Fred Vos <f...@fredvos.org>
Subject Cocoon 2.2 build errors for cocoon-dist-samples
Date Thu, 12 Oct 2006 20:40:10 GMT
Dear developers,

This afternoon I did a fresh download of the Cocoon 2.2 trunk and tried to
build it. Unfortunately I'm getting build errors. Here's the output from
maven. I replaced the actual path to the trunk with '/path/to/cocoon/trunk':

[INFO] Generating war
/path/to/cocoon/trunk/dists/cocoon-dist-samples/target/cocoon-samples.war
[INFO]
------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO]
------------------------------------------------------------------------
[INFO] Error assembling WAR

Embedded error: Deployment descriptor:
/path/to/cocoon/trunk/dists/cocoon-dist-samples/target/cocoon-samples/WEB-INF/web.xml
does not exist.

This cocoon-dist-samples also couses troubles on another machine where I've
tried to build cocoon earlier. After an update to the same revision as in the
previous example and a build attempt, I get the following errors:

[INFO] Assembling webapp cocoon-dist-samples in
/path/to/cocoon/trunk/dists/cocoon-dist-samples/target/cocoon-samples
[INFO]
------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO]
------------------------------------------------------------------------
[INFO] There are at least two artifacts with the ID 'xmlParserAPIs':
xerces:xmlParserAPIs:jar:2.6.2:compile
    org.apache.cocoon:cocoon-dist-samples:war:2-SNAPSHOT
    org.apache.cocoon:cocoon-batik-sample:jar:1.0.0-SNAPSHOT
    org.apache.cocoon:cocoon-batik-impl:jar:1.0.0-SNAPSHOT
    batik:batik-ext:jar:1.6-1
    xml-apis:xmlParserAPIs:jar:2.0.2
xerces:xmlParserAPIs:jar:2.6.2:compile
    org.apache.cocoon:cocoon-dist-samples:war:2-SNAPSHOT
    org.apache.cocoon:cocoon-forms-sample:jar:1.0.0-SNAPSHOT
    org.apache.cocoon:cocoon-forms-impl:jar:1.0.0-M2-SNAPSHOT
    xom:xom:jar:1.1
    xerces:xmlParserAPIs:jar:2.6.2

I removed both directories ~/.m2/repository/xerces and ~/.m2/repository/xml-apis
from my local repository, since these both contain this artifact called
'xmlParserAPIs', hoping one of these was related to another project. But after
a rebuild, both directories are restored again and the problem reappears. Do
you have any clues?

Thanks for your attention,

Fred

Mime
View raw message