cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Laurent Perez" <hak...@gmail.com>
Subject Re: trunk webapp not working under tomcat5.5.17
Date Fri, 08 Sep 2006 21:32:33 GMT
> > I still have a problem gettting cocoon to load my own Spring beans : I
> > put a daoContext.xml file under WEB-INF/cocoon/spring, but when I
> > restart the container it again shows SEVERE : errorListener, nothing
> > else. That file is working fine under spring2.0m4.
> Could you post your whole stacktrace and the context file?

well, there is no stacktrace at all, the catalina log just writes
"SEVERE : errorListener" and prevents the webapp from deploying. I'll
try to figure out if tomcat startup can be set to some DEBUG loglevel.

I tried to change my context to a very basic one, with a root <beans>
and a single <bean> entry, and it shows the same error. I then tried
to add a <bean> entry to WEB-INF/applicationContext.xml and it also
outputs that error, I'm pretty lost, but yeah I'll post that file
later on. Note that the single <bean> I tried to add is a
org.springframework.jdbc.datasource.DriverManagerDataSource class.

I also stumbled across
http://www.mail-archive.com/dev@cocoon.apache.org/msg46302.html , does
it mean I have to put a <cocoon:"something"/> tag somewhere into my
context ?

> > how do I tell cocoon to load my own beans ?
> you simply put context definitions into WEB-INF/cocoon/spring directory

yep, that's the first thing I tried.

laurent

Mime
View raw message