cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Stevens" <at...@hotmail.com>
Subject Re: [Vote] Java 5 as minimum JDK requirement
Date Fri, 18 Aug 2006 14:57:27 GMT
>From: Sylvain Wallez <sylvain@apache.org>
>Date: Fri, 18 Aug 2006 10:00:59 +0200
>
>Joerg Heinicke wrote:
> > On 17.08.2006 01:29, Torsten Curdt wrote:
> >
> >>> "Is it appropriate to vote according to your employer's needs".
> >>
> >> IMO PMC members should vote in the best interest of the project - not
> >> in the best interest of their employers.
> >
> > I just want to point out that I did not vote "according to [my]
> > employer's needs", but what IMHO is better for the project. Though we
> > do not yet use Java 5, there is probably no problem to switch to it.
> > The example I made with the bank was with a former employer of mine.
>
>
>Folks, this discussion considers the problem from the wrong perspective.
>
>Large IT departments don't bother upgrading their environments unless
>there's a compelling reason to do that,

Oh, we already have a compelling reason - Websphere 5.0's end-of-lifed at 
the end of next month.  Unfortunately, I was informed by the team that looks 
after the servers that they hadn't finished testing a newer version (and had 
found some issues with it affecting some of our apps that would need to be 
fixed before they'd sign it off) and were negotiating with IBM to continue 
supporting the older version for us in the meantime.  And we're big enough 
that they'll probably do it :-(

>and if we listen to them, we'll
>never move forward. Now being told "the new version of the application
>needs the great things brought by the new Cocoon, but requires Java 1.5"
>can be such an incentive for them. Even if I don't think people
>frightened by the migration from Java 1.4 (or 1.3) to 1.5 will even
>consider migrating from Cocoon 2.1 to 2.2.

If only life were that simple.  Personally, I'd love to switch to 1.5, and 
in fact am using it on my "spare time" projects at home.  But I have no 
influence on which version to use at work - if our site it to be hosted on 
the robust, scalable infrastructure in the US datacentre, then we have to 
code to the server that they support.  For internal apps it's another 
matter, but for internet sites we're stuck with the "group standard" 
platform.  If I argue "but Cocoon needs 1.5", they'll just tell me I should 
instead migrate our app to the proprietary web app framework we inherited in 
a takeover a while back, and which is supported & maintained by yet another 
team over in the States.  I only get to use Cocoon (which is a much better 
fit with our CMS, that uses XML-based data records) because they also 
support bare servlets/JSPs and we told them it's "just" an XML processing 
servlet :-)

>It is IMO our role, as technology builders, to invite our users to
>progress towards more modern stuff. What's the purpose of Sun releasing
>a new JDK? What's the reason for Cocoon to release 2.2? What's the
>reason to upgrade to the latest Xalan? What's the reason for Struts to
>start with a blank page learning from the oldish Struts 1.x and Webwork?
>Providing more to users, providing something that works better,
>providing something that brings more development productivity.

There's a difference between "inviting users to progress towards more modern 
stuff" and forcing them to leap to the cutting edge, though.  What's wrong 
with one step at a time?  JDK 1.3 for Cocoon 2.1.x, JDK 1.4 for Cocoon 2.2, 
JDK 1.5 for Cocoon 3 or 2.3 or whatever the next version gets called?

One of the good things about Cocoon (IMO) is that it cares about backwards 
compatibility - 2.1.x requires only java 1.3 and servlet 2.2 so will run on 
just about anything.  There was a recent vote to move trunk/2.2 to servlet 
2.4, justified by Tomcat 5.0 being available since 2003; since Tomcat 5.0 
requires JDK 1.4 or later, why not keep in line with that?  If you're going 
to switch to 1.5 just because it's the current version, you might as well go 
the whole hog and jump to servlet 2.5/J2EE 5 too...

>All this discussion makes me sad, as it gives the impression the overall
>Cocoon developer community doesn't want to move forward and is
>frightened by moves that would cause some disruption among _some_ users.

Not so much frightened as that they care, and not only want to move forward 
but bring existing users forward with them.  At least, that's the impression 
I receive.

>Note also that the poll on the user list showed an evident interest in
>using JDK 1.5...

If I remember rightly, the summary that was posted here a couple of days ago 
was that 9 users said it wouldn't be a problem for them.  Count me as 1 
against that and extrapolate, and we could conclude jumping to 1.5 is a 
problem for 10% of your users.  Given the statistical error on such a small 
sample size, I could probably come up with figures to prove it 
inconveniences anything between one user and most of the user base.  But 
that's what a couple of years studying statistics gets you :-)


Andrew.



Mime
View raw message