cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Torsten Curdt" <tcu...@apache.org>
Subject Re: Re: [Vote] Java 5 as minimum JDK requirement
Date Fri, 11 Aug 2006 01:45:24 GMT
> I've been thinking the same for two years, recently started a new
> project on java 5, and yes, it is better from a coding point of view.
> Brings more or less nothing to the final user, except better written
> code, which is not nothing at all.

+1

> But again, for those users that have a strict need for 1.4, what about
> tools like http://retroweaver.sourceforge.net/ or
> http://retrotranslator.sourceforge.net/ which also have a maven plugin?
> I'm testing my java 5 application, retro-compiled to java 4, and it
> seems to work correctly.

It should as the byte-code itself is not really different at all.
IMO an alternative worth thinking about.

cheers
--
Torsten

Mime
View raw message