cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rice Yeh" <>
Subject Re: Run myBlock in Tomcat fail
Date Wed, 02 Aug 2006 06:36:14 GMT
  Seems it is classloader problem because CocoonServletListener.class
is not found.
. See the following error message:

Aug 2, 2006 2:26:02 PM org.apache.catalina.core.StandardContext listenerStart
SEVERE: Error configuring application listener of class
	at org.apache.catalina.loader.WebappClassLoader.loadClass(
	at org.apache.catalina.loader.WebappClassLoader.loadClass(
	at org.apache.catalina.core.StandardContext.listenerStart(
	at org.apache.catalina.core.StandardContext.start(
	at org.apache.catalina.manager.ManagerServlet.start(
	at org.apache.catalina.manager.HTMLManagerServlet.start(
	at org.apache.catalina.manager.HTMLManagerServlet.doGet(
	at javax.servlet.http.HttpServlet.service(
	at javax.servlet.http.HttpServlet.service(
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(
	at org.apache.catalina.core.StandardWrapperValve.invoke(
	at org.apache.catalina.core.StandardContextValve.invoke(
	at org.apache.catalina.authenticator.AuthenticatorBase.invoke(
	at org.apache.catalina.core.StandardHostValve.invoke(
	at org.apache.catalina.valves.ErrorReportValve.invoke(
	at org.apache.catalina.core.StandardEngineValve.invoke(
	at org.apache.catalina.connector.CoyoteAdapter.service(
	at org.apache.coyote.http11.Http11Processor.process(
	at org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(
	at org.apache.tomcat.util.threads.ThreadPool$
Aug 2, 2006 2:26:02 PM org.apache.catalina.core.StandardContext listenerStart
SEVERE: Skipped installing application listeners due to previous error(s)

>> Rice Yeh wrote:
>> Hi,
>>   I have checked the web.xml and the doctype is ok. I run it in
>> tomcat-5.0.28 and the error messages seems showing the problem is about the
>> context listener. Hence, I comment out the listener setting in web.xml, then
>> the error becomes  "Error filterStart". From here, I resaon it is context
>> listener problem.
> I just rechecked with latest version of trunk. At least on my machine it
> runs without any problems on Tomcat 5.0.28 and 5.5.12.

> Can you send your complete tomcat log for more information?

> Carsten

View raw message