cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joerg Heinicke <joerg.heini...@gmx.de>
Subject Re: [Result] [Vote] Java 5 as minimum JDK requirement
Date Thu, 17 Aug 2006 23:00:29 GMT
On 15.08.2006 17:28, Jason Johnston wrote:

> I am interested (and I think the community needs to know) what 
> Joerg's criteria for approving an eventual move to 1.5 would need to be, 
> in some measurable way.  I'm sure he would agree that at some point in 
> the future moving to 1.5+ will be appropriate, but how will we know when 
> that time has come?

That's indeed a very difficult question. And there is probably nothing 
measurable. I argued with the silent user base still using Java 1.4 - 
they will probably also not stand up and shout "Now we us Java 5, you 
can switch."

But I trust in our community health. Just have a look around on 
comparable frameworks and see what they are doing. I mentioned Spring. 
Geronimo is another case: Still a J2EE 1.4 server they think about JEE 5 
- and so Java 5. But they also think about Java 1.4 compatibility, be it 
via retro* or via plugins. Unfortunately they came not really into 
discussion about this topic [1], but went on to JPA.

Another question is about the efforts according to the libraries we are 
using. At the moment I don't know any actually requiring Java 5. And a 
framework should IMHO definitely not walk in the first line.

So, no, I don't have anything measurable. And we will probably have to 
think about this topic again, be it in one year or with the next minor 
or major version of Cocoon.

Jörg

[1] http://marc.theaimsgroup.com/?t=115506018700005&r=1&w=4

Mime
View raw message