cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joerg Heinicke <joerg.heini...@gmx.de>
Subject Re: [Vote] Java 5 as minimum JDK requirement
Date Mon, 14 Aug 2006 23:41:19 GMT
On 11.08.2006 20:41, Don Brown wrote:

> Actually, you'd be surprised to what Retroweaver/Retrotranslator can
> handle.  Stripes, a Java 5 annotation-heavy web framework recently
> used it to allow Java 1.4 apps to use Stripes, despite using new Java
> 5 methods, annotations, and other features quite heavily.  We (Struts)
> are planning on using Retrotranslator to support Java 1.4, while
> taking full advantage of Java 5 annotations and new class methods.

It can handle changes in the APIs like 
https://svn.apache.org/viewvc?view=rev&revision=422219 (Java 1.3 vs. 
1.4)? Or maybe even JDBC 3.0 vs JDBC 2.0? How is it doing it?

Jörg

Mime
View raw message