cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Fagerstrom <>
Subject Re: [Vote] Java 5 as minimum JDK requirement
Date Thu, 10 Aug 2006 09:41:42 GMT
Joerg Heinicke skrev:
> On 08.08.2006 18:47, Jorg Heymans wrote:
>>> As Java 5 was released almost 2 years ago, I propose making it the
>>> minimum requirement for trunk and all artifacts released from there.
>> -0, because this means eliminating cocoon 2.2 on "older" application
>> servers eg weblogic 8.1.
IIUC weblogic 8.1 uses servlet 2.3 so I guess you need to veto the use 
of servlet 2.4 to make this a valid point.

If there are other use cases that require Java 1.4 you should seriously 
consider if Simones proposal of using the Retroweaver would be enough.

>> Frankly, I don't see the point in upgrading unless there's a killer
>> feature in 1.5 that
>> 1) we are likely to use and implement in the near future (2006) and,
>> 2) will improve cocoon by a significant margin.
We never require something like that when we update the version on 
libraries we depend on. For libraries we depend on the latest stable 
version as long as it doesn't create any problems, we never require that 
anybody is going to use the latest features.

> I second this, but vote even -1. I wonder why a framework should set 
> such high requirements. Have a look on spring. They have a Java 1.3 as 
> minimum requirement and only need Java 5 for special features.
> IMO we should do it in a similar manner and not set the general 
> requirement to Java 5.
Cocoon is both a framework and a set of applications. Compared to 
Spring, Cocoon is less framework oriented. If you want to follow the 
Spring policy I think you should formulate an alternative proposal which 
describes when it is OK to use Java 5 and when it is not.


View raw message