cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Reinhard Poetz <reinh...@apache.org>
Subject Re: [Vote] Java 5 as minimum JDK requirement
Date Thu, 10 Aug 2006 05:53:19 GMT
Jorg Heymans wrote:
> Reinhard Poetz wrote:
>> As Java 5 was released almost 2 years ago, I propose making it the
>> minimum requirement for trunk and all artifacts released from there.
>>
> 
> -0, because this means eliminating cocoon 2.2 on "older" application
> servers eg weblogic 8.1.
> 
> Frankly, I don't see the point in upgrading unless there's a killer
> feature in 1.5 that
> 1) we are likely to use and implement in the near future (2006) and,
> 2) will improve cocoon by a significant margin.


I've been thinking about your reasoning some time and believe you're right, 
there is no killer argument that makes it impossible to continue the development 
of Cocoon. There are many new features in Java 5 which make the life of 
developers easier and as Java 5 was released almost 2 years ago I and many other 
people on this list believe that's long enough. Additionally there is no 
existing user base.

As Vadim pointed out that this is our _framework developer_ point of view that 
might not reflect the community as a whole. He proposed to poll user@cocoon 
which I will do today.

I will keep the vote open till next week so that you can consider the outcome of 
the poll. Having said this I want to stress that there is no pressure to change 
your opinion because of the poll in any way.

-- 
Reinhard Pötz           Independent Consultant, Trainer & (IT)-Coach 

{Software Engineering, Open Source, Web Applications, Apache Cocoon}

                                        web(log): http://www.poetz.cc
--------------------------------------------------------------------

		
___________________________________________________________ 
Telefonate ohne weitere Kosten vom PC zum PC: http://messenger.yahoo.de

Mime
View raw message