cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Antonio Gallardo <agalla...@agssa.net>
Subject Re: [Vote] Java 5 as minimum JDK requirement
Date Wed, 09 Aug 2006 02:14:22 GMT
Jason Johnston escribió:
> On Tue, 2006-08-08 at 08:05 -0600, Jason Johnston wrote:
>   
>> Reinhard Poetz wrote:
>>     
>>> As Java 5 was released almost 2 years ago, I propose making it the 
>>> minimum requirement for trunk and all artifacts released from there.
>>>
>>>       
>> +1
>>     
>
> Thinking about this a bit more, I have a question.
>
> As I understand it there are several blocks (CForms comes to mind) that
> are shared between trunk and the 2.1.x branch via svn:external
> properties.  Unless I'm mistaken this would prevent the minimum JDK
> requirement from being raised for these blocks, since it would affect
> the branch where Java 1.3 is still supported.  Using any new JDK
> features in these blocks would break that 1.3 support in the branch.
>
> Should the vote be qualified with an "...except for those blocks that
> are shared by the 2.1.x branch"?
>   
Good point. BTW, what if we vote to upgrade 2.1. branch to at least 1.4? :-)

Best Regards,

Antonio Gallardo.

Mime
View raw message