cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Don Brown" <donald.br...@gmail.com>
Subject Re: [Vote] Java 5 as minimum JDK requirement
Date Fri, 11 Aug 2006 18:41:02 GMT
On 8/10/06, Joerg Heinicke <joerg.heinicke@gmx.de> wrote:
> > If there are other use cases that require Java 1.4 you should seriously
> > consider if Simones proposal of using the Retroweaver would be enough.
>
> This works only as long as you don't use extensions made to the JDK
> classes. Different JDK versions are not just about language features but
> also about APIs. So this is no replacement IMO.

Actually, you'd be surprised to what Retroweaver/Retrotranslator can
handle.  Stripes, a Java 5 annotation-heavy web framework recently
used it to allow Java 1.4 apps to use Stripes, despite using new Java
5 methods, annotations, and other features quite heavily.  We (Struts)
are planning on using Retrotranslator to support Java 1.4, while
taking full advantage of Java 5 annotations and new class methods.

Don

Mime
View raw message