cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ralph Goers <Ralph.Go...@dslextreme.com>
Subject Re: [RANT] This Maven thing is killing us....
Date Tue, 04 Jul 2006 20:59:47 GMT


Carlos Sanchez wrote:
> If project A says it depends on B 1.0 and C says it depends on B 1.1,
> there's a conflict in Maven, Ant and anything you want to use, the
> difference is that Maven tries to do it for you, but you still can
> override that behaviour.
Actually, you can't in Maven 2 - at least not in any rational manner - 
until http://jira.codehaus.org/browse/MNG-1577 is addressed.  The good 
news is that there is a strong desire to move to Maven 2 in my 
organization, so I may be given some time soon to do something about this.

However, this isn't even the biggest problem that has been hampering the 
Cocoon community. It is that there seems to be at best a 50% chance of 
getting a Maven 2 based Cocoon build to work due to dependencies failing 
to download from repositories.  Cocoon also consistently uses snapshot 
versions of some of its dependencies. While this isn't desirable, it is 
a fact of life.  From Cocoon's perspective we really need to treat them 
like they are a "private" release - i.e. they weren't formally released 
from wherever they came from, but we don't want to have to download them 
at every build since they will never change.

Ralph

Mime
View raw message