cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jorg Heymans ...@domek.be>
Subject Re: Build error in 2.2
Date Thu, 29 Jun 2006 16:18:27 GMT

Carsten Ziegeler wrote:

>> While building the ajax block in 2.2 I get the following error:
>>
>> [INFO] The plugin 'org.apache.maven.plugins:maven-antrun-plugin' does
>> not exist
>> or no valid version could be found
>>
>> Shouldn't maven automatically download the plugin?
>>
>> Carsten
>>
> I fixed this by adding a version to the plugin info in the ajax impl
> pom. Don't know if that is the correct solution?
> 

My guess is that you hadn't used the maven-antrun-plugin before. Maven
then needs the version number in order to retrieve it. If you have
installed it locally it defaults to the latest version available in the
local repository.

Specifying plugin versions is always good, if nothing else it will
prevent maven from using any other plugin version when the users forces
plugin updates.


Jorg


Mime
View raw message