cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jorg Heymans ...@domek.be>
Subject Re: Maven dependencies
Date Wed, 10 May 2006 17:13:48 GMT

Giacomo Pati wrote:

> I've run a little script agains the code base. We already have
> dependencies of the same artifact with different versions:
> 
> POM: ./blocks/cocoon-portal/cocoon-portal-impl/pom.xml
>         group=castor    artifact=castor version=0.9.6
> POM: ./blocks/cocoon-scratchpad/cocoon-scratchpad-impl/pom.xml
>         group=castor    artifact=castor version=0.9.7
> POM: ./blocks/cocoon-chaperon/cocoon-chaperon-impl/pom.xml
>         group=castor    artifact=castor version=0.9.7
> POM: ./tools/cocoon-block-deployer/cocoon-deployer-core/pom.xml
>         group=castor    artifact=castor version=1.0M1
> 
> POM: ./core/cocoon-blocks-fw/cocoon-blocks-fw-demo2/pom.xml
>         group=org.apache.cocoon artifact=cocoon-blocks-fw-impl 
> version=1.0.0-SNAPSHOT
> POM: ./core/cocoon-blocks-fw/cocoon-blocks-fw-servlet-impl/pom.xml
>         group=org.apache.cocoon artifact=cocoon-blocks-fw-impl 
> version=1.0-SNAPSHOT
> 
> POM: ./core/cocoon-core/pom.xml
>         group=org.apache.excalibur.components.sourceresolve    
> artifact=excalibur-sourceresolve        version=2.1
> POM: ./blocks/cocoon-scratchpad/cocoon-scratchpad-impl/pom.xml
>         group=excalibur-sourceresolve  
> artifact=excalibur-sourceresolve        version=2.1
> 
> POM: ./tools/cocoon-block-deployer/cocoon-deployer-core/pom.xml
>         group=oro       artifact=oro    version=2.0.7
> POM: ./blocks/cocoon-forms/cocoon-forms-impl/pom.xml
>         group=oro       artifact=oro    version=2.0.8
> 

Thanks, that output is very useful. I'll go and fix these right away.

It would be great if you could run that script every now and then so we
  can keep the dependency beast tamed.

> What should we do with those?

Fail early i'ld say, we upgrade all of them to the highest version
currently used and see how it goes.

 ----

Antonio's concern about the osgi block isolation is valid, but IMO it
does not apply as long as we haven't got it fully working. Consequently
there is no reason trying to accomodate for it now.


Regards
Jorg


Mime
View raw message