cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Carsten Ziegeler <cziege...@apache.org>
Subject Re: [2.2] Error building trunk
Date Fri, 19 May 2006 14:28:42 GMT
Reinhard Poetz wrote:
> Carsten Ziegeler wrote:
>> After the recent changes to our poms, I get the following error:
>>
>> It seems that we are now using the wrong xml-apis version for compilation.
> 
> sorry, was my fault. I forgot to checkin some changes. The problem is that 
> Xerces 2.8.0 has a transitive dependency on xml-apis 1.3.03.
> 
> I'm not a DOM specialist, but could somebody upgrade the three or four classes 
> that have problems with 1.3.03 so that they work together?
> 
The problem is that the version used by Xerces only supports Dom-level 2
while we support
DOM level 3 in some classes. I think we can just keep our own dependency
to xml-apis and are done.

Carsten
-- 
Carsten Ziegeler - Open Source Group, S&N AG
http://www.s-und-n.de
http://www.osoco.org/weblogs/rael/

Mime
View raw message