cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sylvain Wallez <sylv...@apache.org>
Subject Re: Running Cocoon in OSGi mode
Date Tue, 25 Apr 2006 09:19:20 GMT

>>>> I followed the instructions:
>>>>
>>>> $ mvn c-eclipse:eclispe -o
>>>>
>>>> didn't work
>>>>
>>>> [ERROR] BUILD ERROR
>>>> [INFO] The plugin 'org.apache.maven.plugins:maven-c-eclipse-plugin'
>>>> does not exist or no valid version could be found
>>
>>
>> Now it works for core/cocoon-core but still not for core, (which is
>> needed for geting the blocks fw).
>>
>>>> After having started the OSGi framework I get a
>>>>
>>>> java.lang.NoClassDefFoundError:
>>>> org/springframework/beans/factory/BeanFactory
>>
>>
>> Works now. The test page also works.
>>
>> I get the error:
>>
>> Cannot nest output folder
>> 'cocoon-blocks-fw-impl/target/classes/META-INF' inside output folder
>> 'cocoon-blocks-fw-impl/target/classes'        cocoon-blocks-fw-impl  
>> in Eclipse (3.2RC1).
>
> I see. I will try to find a solution for this and get in contact with
> the PDE devs as the problem is that our META-INF is not in
> src/main/resources but in the root directory because of PDE requirements.

Guys, I don't know about you, but this discussion gives me the feeling
that we're now totally out of control of our own code base. Being unable
to run Cocoon and having to ask the PDE guys at Eclipse for this is
frightening me...

Sylvain

-- 
Sylvain Wallez - http://bluxte.net


Mime
View raw message