cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Carsten Ziegeler <cziege...@apache.org>
Subject Re: Activate the new template block by default in 2.1.x?
Date Tue, 11 Apr 2006 17:20:30 GMT
Jean-Baptiste Quenot wrote:
> * Bertrand Delacretaz:
> 
>> Another option is to activate  the new template block by default
>> in 2.1.x, but  this means 2.1.x wouldn't compile out  of the box
>> with JDK 1.3 anymore.
> 
> I would  make a new release  with the template block  activated by
> default, and if possible make it JDK 1.3 compliant.
I think enabling/disabling a block is not enough for a new release.
But I agree that we should try to make the template block compile with
JDK 1.3 as we see it as an important block.

But we should enable it by default for 2.1.x again and provide a clear
message so users notice what the problem is if they compile Cocoon using
JDK 1.3 and get some obscure java compilation problems.

Carsten
-- 
Carsten Ziegeler - Open Source Group, S&N AG
http://www.s-und-n.de
http://www.osoco.org/weblogs/rael/

Mime
View raw message