cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Antonio Gallardo <agalla...@agssa.net>
Subject [RT] Set min JVM to 1.4 after 2.1.9?
Date Fri, 24 Mar 2006 17:48:41 GMT
Hi:

Facts:

1. We are not able to update some libraries. ie: lucene, itext,  eclipse 
jdt compiler, joost, icu4j, and the list is growing every day.
2. There are some blocks that "silently" does not compile in 1.3 at all. 
ie: faces, jcr.
3.  There are some blocks that compiles using Java 1.3 but don't run.
4. Java 1.6 (Mustag) already released a beta. Once it will be out, we 
will have "in hands" 4 different JVM to care of.

As we see, Java 1.3 is stoping us in many ways, hence "the need" for 
raising the minimal required JVM version for 2.1.x branch.

Perhaps, we should do a note about this in the 2.1.9 Release Notes. That 
way our users will have time to prepare for switching JVM.

WDYT?

Best Regards,

Antonio Gallardo.

Mime
View raw message