cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Stevens" <at...@hotmail.com>
Subject Re: Error message when checking out 2_1_X branch
Date Thu, 09 Feb 2006 18:56:42 GMT
>From: Antonio Gallardo <agallardo@agssa.net>
>Date: Tue, 07 Feb 2006 13:11:26 -0600
>
>Andrew Stevens wrote:
>
>>>From: Antonio Gallardo <agallardo@agssa.net>
>>>Date: Tue, 07 Feb 2006 11:37:59 -0600
>>
>>...
>>
>>>cd check out directory and run 'svn up' again.
>>
>>
>>Nope, no difference.
>>
>>C:\development\cocoon\BRANCH_2_1_X>svn up
>>svn: REPORT request failed on '/repos/asf/!svn/vcc/default'
>>svn: REPORT of '/repos/asf/!svn/vcc/default': 400 Bad Request 
>>(http://svn.apache.org)
>
>Hmm.... this might happens when the apache svn server is too busy or a 
>problem in the network. A hint, is the connection loosing TCP packages?
>
>Anyway, please keep trying the 'svn up' command. This command should 
>sucessfully end.
>
>I just did a svn up to confim and it is working to me.

I tried again at various times over the last couple of days, and kept 
getting the error.  So this morning I tried from home on a laptop, and it 
worked fine.  Doing a diff of the directories, I found that the files that 
were missing on my work machine were all in the jcr block, ajax block, 
captcha block, forms block, and validation block (everything but their conf 
directories).  And what is it that uses svn externals in the repository?  
The jcr block, ajax block, captcha block, forms block and validation block, 
except for their conf directories...

I don't believe it's a coincidence.  It looks like the externals are causing 
Bad Request errors when accessed through our office proxy server :-(  I'm 
guessing perhaps it's due to the use of https in the external configurations 
when I'm using http in the repository URL?
Oh well, at least I've now got the copy from the laptop to work with.


Andrew.



Mime
View raw message