cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Fagerstrom <dani...@nada.kth.se>
Subject Re: building trunk
Date Sun, 12 Feb 2006 10:17:52 GMT
It is a very primitive demo, there is no index file or interesting 
content. Point to 
http://localhost:8888/cocoon-blocks-fw-sample/test1/test and see if you 
get an xml response with the single element <test/>.

I also get a faulty redirection error from Firefox while pointing to 
http://localhost:8888/cocoon-blocks-fw-sample/, I don't know what is the 
problem. There is some redirection code that puts a "/" in the end of an 
empty path in o.a.c.blocks.servlet.BlocksManager.service that I copied 
from the CocoonServlet without understanding it ;) Maybe it creates some 
problem in this context.

/Daniel

Ralph Goers skrev:
> I updated. Now I get a pop-up from Firefox saying that the redirection 
> limit for the url has been exceeded.  The window where I ran maven shows 
> a NullPointerException in CoreServiceManager.lookup() at line 390.
> 
> Daniel Fagerstrom wrote:
>> Sounds like a problem that I introduced in a refactoring early this 
>> week and removed in revision 376095.
>>
>> Have you updated to that revision?
>>
>> /Daniel
>>
>> Ralph Goers wrote:
>>> Well, it almost worked.  It started up but when I entered the url in 
>>> the browser I got
>>> javax.servlet.ServletException: Couldn't find 
>>> COB-INF/block-sitemap.xmap.
>>>
>>> Reinhard Poetz wrote:
>>>
>>>> Ralph Goers wrote:
>>>>
>>>>> OK.  I am now able to build trunk.  Now what?  Does anything run at 
>>>>> the moment?
>>>>
>>>>
>>>> Yes, ./trunk/cocoon-blocks-fw/cocoon-blocks-fw-sample/ (just call 
>>>> 'mvn package jetty6:run' from the module's base directory) should be 
>>>> useable again and I plan to make the first tutorial 
>>>> (https://issues.apache.org/jira/browse/COCOON-1750) work today (MET).
>>>>
>>


Mime
View raw message