cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ralph Goers <Ralph.Go...@dslextreme.com>
Subject Re: 2.1 portal won't compile in jdk 1.3
Date Fri, 03 Feb 2006 09:05:35 GMT
BTW - I have thought of two ways to fix this. (I'd post this on 
wsrp4j-dev, but it appears that list is moderated - I responded to the 
subscribe but I haven't gotten a response saying I'm subscribed).

1. 

super(Messages.get(errorCode));
try
{
    this.initCause(t);
}
catch (Exception e)
{
   // Ignore the error on JDK 1.3
}

2.  Use the technique I am using to fix EncodeURLTransformer. I'm adding 
a jdk1.4 and jdk1.3 directory under src.  The build system will use the 
appropriate one depending on the target jvm version.

Ralph


Carsten Ziegeler wrote:

>Ralph Goers schrieb:
>  
>
>>Nope. WSRPException does a super on Exception(String message, Throwable 
>>t) which is only available in JDK 1.4 So either this class needs to be 
>>modified or the doc at 
>>http://portals.apache.org/wsrp4j/gettingstarted/installation.html is 
>>wrong and wsrp4j requires JDK 1.4.  The subversion history indicates 
>>this class has been this way since it was created in December 2003.
>>
>>    
>>
>WSRP and Pluto require servler 2.3 - now WSRP4J is about to move to a
>cleaned up code base which uses maven (or perhaps m2) very soon. I'll
>have a look at the JDK 1.4 issue as soon as that move takes place.
>
>Thanks
>Carsten
>
>
>
>  
>

Mime
View raw message