cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ben Pope <benpop...@gmail.com>
Subject M10N
Date Sun, 15 Jan 2006 00:44:00 GMT
Hi,

I am currently unable to get the 2.2 trunk working with maven, as
descibed in the docs.  It might just be that it's broken what with all
the refactoring, I dunno.

I've been following this page:
http://cocoon.zones.apache.org/daisy/documentation/g2/756.html

When "Building Cocoon Block Deployer"
I get a compile error:
java.lang.IllegalStateException: basedir src\main\resources\xsd does not exist

I can compile successfully if I remove both
<module>cocoon-deployer</module>
<module>cocoon-plugins</module>
from the top-level pom.xml

OK, that seems to work and I can successfully run jetty6.

I then try to create my own block and webapp using the instructions here:
http://cocoon.zones.apache.org/daisy/documentation/g2/796.html
and here:
http://cocoon.zones.apache.org/daisy/documentation/g2/797.html

But both fail with a file that cannot be downloaded:
Downloading: http://repo1.maven.org/maven2/org/apache/cocoon/block/1.0/block-1.0.jar
[WARNING] Unable to get resource from repository central
(http://repo1.maven.org/maven2)
and
Downloading: http://repo1.maven.org/maven2/org/apache/cocoon/webapp/1.0/webapp-1.0.jar
[WARNING] Unable to get resource from repository central
(http://repo1.maven.org/maven2)

Are these things known to be broken?  Whats the current workaround?

If the current workaround is to wait 'til it works, then thats ok :P

Thanks for your time,
Ben Pope.

Mime
View raw message