cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Carsten Ziegeler <cziege...@apache.org>
Subject Re: Update to the Servlet API
Date Wed, 25 Jan 2006 14:53:54 GMT
Sylvain Wallez wrote:
> Carsten Ziegeler wrote:
>> Jean-Baptiste Quenot schrieb:
>>   
>>> I wish  to replace servlet_2_2.jar with  servlet_2_3.jar, but keep
>>> compatibility  with servlet  2.2,  by making  servlet2.3-requiring
>>> components optional.
>>>     
>> You can't check if a component uses 2.3 functionality, so if we just
>> upgrade we might end up with a not 2.2 servlet compliant solution. (Or
>> is there a way?)
>>   
> 
> Servlet 2.3 has been released more than 4 years ago[1]. IMO it is safe 
> to consider that people using recent versions of Cocoon are running at 
> least servlet 2.3 and most probably servlet 2.4.
> 
> So depending on servlet 2.3 shouldn't be that much of a problem.
> 
Yes, that's why I said in an earlier response that we can vote on
upgrading the requirements to servlet 2.3 officially.

Carsten
-- 
Carsten Ziegeler - Open Source Group, S&N AG
http://www.s-und-n.de
http://www.osoco.org/weblogs/rael/

Mime
View raw message