cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Quenot <>
Subject Re: Update to the Servlet API
Date Wed, 25 Jan 2006 16:03:17 GMT
* Carsten Ziegeler:

> Sylvain Wallez schrieb:
> > Jean-Baptiste can elaborate on this, but AFAIU this is because
> > an interesting XSP patch requires a servlet listener, which is
> > something that was added in servlets 2.3.
> So, he could just  add a mock class for the  listener to the xsp
> block, add the listener and we are done with this.

Yes, I want to integrate a  patch that allows to run an *optional*
component  on  webapp  startup  to compile  XSP.   It's  only  for
*compilation* that servlet 2.3 is  needed, not for runtime, unless
the user  explicitly activates  in web.xml the  optional component
(it's a SessionListener).

Servlet 2.3 will *not* be required to run Cocoon.
Jean-Baptiste Quenot

View raw message