cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sylvain Wallez <sylv...@apache.org>
Subject Re: Compilation problems 2.2 with Eclipse
Date Fri, 23 Dec 2005 11:02:12 GMT
Jean-Christophe Kermagoret wrote:
> Hi,
> I downloaded a svn version of the trunk 2-3 days ago and started to
> compile it the usual way (build.bat then cocoon.bat servlet) :
> everything works like a charm.
>
> When I start to compile it with eclipse, I have errors in session-fw
> about SessionManager not found in the project. If I just touch the
> source files that have problem in the session-fw block, the files
> compile !!!
>
> So I finally end with a cocoon compiled.
>
> Then I start cocoon servlet and errors appear :
> * my WEB-INF/lib is empty and I'm using the CocoonServlet in web.xml, it
> does not find the org/apache/common/langs/exception/NestableException
>
> * if I had the common-lang.jar in the endorsed lib, I have another error
> about excalibur
>
> Then I put all the libs I have in the optional lib directory in the
> WEB-INF/lib and I use ParanoidCocoonServlet.
>
> I can see all the libs loading, and I finish with an error about the
> ParanoidServlet that can't be initialized
>
> Any ideas ?

Yep. This is because there are some mock classes for session-fw in the 
xsp block (why?). Just remove the xsp/trunk/mocks directory from the 
eclipse sourcepath. That should solve the problem.

Sylvain

-- 
Sylvain Wallez                        Anyware Technologies
http://bluxte.net                     http://www.anyware-tech.com
Apache Software Foundation Member     Research & Technology Director


Mime
View raw message