cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christoph Hermann <christoph.herm...@guschtel.de>
Subject Re: Exception using auto-generated Forms in 2.1.8
Date Mon, 19 Dec 2005 18:54:30 GMT
Am Montag, 19. Dezember 2005 16:57 schrieb Sylvain Wallez:

Hello,

> > I don't know if this should be like this, i just wanted to inform you:
> >
> > In 2.1.8 i get an exception using this construct:
> >
> > <ft:widget id="substring">
> > 	<fi:styling list-type="checkbox" checked="checked" />
> > </ft:widget>
> >
> > whereas it worked fine in 2.1.7.
> >
> > If i change the fi:styling to ft:styling (i vs t) everything is fine
> > (took me really long to find this!).
>
> Is the "fi:" namespace declared in whatever (looks like a complicated
> setup) generates <fi:styling> ?

Yes, i have both Namespaces declared.

I have no Idea what causes the error, because in 2.1.7 and some version of 
2.1.8-dev (before the release) it worked fine. 
I just discovered this error when writing some ant scripts that automatically 
build the app from cocoon-src, eXist xmldb, and some other stuff.

BTW. the new error stacktrace was really helpful! :-)

If you need more Information, just ask, for me the problem is "solved" atm.

The template and definition for the form is automatically built using some 
xsls and xml config files. Not really complicated, but very easy to use 
afterwards (even if it mixes up model and view a little bit).

Christoph

Mime
View raw message