cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stefan Pietschmann" <dev.sen...@gmail.com>
Subject AW: Very basic problem with custom Avalon component
Date Mon, 05 Dec 2005 08:21:42 GMT
Ah.. I see. I had a .roles file first, but then decided to put it back to
cocoon.xconf. 

Thanks Sylvain :)

| -----Urspr√ľngliche Nachricht-----
| Von: Sylvain Wallez [mailto:sylvain@apache.org]
| Gesendet: Montag, 5. Dezember 2005 09:11
| An: dev@cocoon.apache.org
| Betreff: Re: Very basic problem with custom Avalon component
| 
| Stefan Pietschmann wrote:
| > Hi Cocooners,
| >
| > something's going wrong with my first Avalon experiments.
| > I stripped it down to this simple case - i just don't seem to find out
| what
| > the problem with this is:
| >
| > ## cocoon.xconf ######################################
| >
| > <component role="de.foo.bar.TestComponent" shorthand="test"
| > default-class="de.foo.bar.impl.TestComponentImpl"/>
| >
| 
| That should be class="de.foo.bar.impl.TestComponentImpl". The
| default-class attribute is for cocoon.roles, and is used when a
| component is looked up but no explicit declaration exists in cocoon.xconf.
| 
| > Why oh why?
| >
| 
| Because ExcaliburComponentManager doesn't check if there's a class name :-
| /
| 
| Sylvain
| 
| --
| Sylvain Wallez                        Anyware Technologies
| http://bluxte.net                     http://www.anyware-tech.com
| Apache Software Foundation Member     Research & Technology Director


Mime
View raw message