cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From 黄 海冬 <lingererhu...@hotmail.com>
Subject portal+cform+ajax problem in 2.1.8 rc1
Date Mon, 07 Nov 2005 16:07:06 GMT
Hi,all
  I try to combine portal+form(with ajax) in 2.1.8 rc1,all is fine but one 
problem,I don't know if is a bug,and just show my step here:
  1.change block portal in samples,copletdata.xml,config like:
     <coplet-data id="app-test-two" name="standard">
      <title>Application Test</title>
      <coplet-base-data>CachingURICoplet</coplet-base-data>
      <attribute>
         <name>buffer</name>
         <value xsi:type="java:java.lang.Boolean">true</value>
      </attribute>
      <attribute>
         <name>handleParameters</name>
         <value xsi:type="java:java.lang.Boolean">true</value>
      </attribute>
      <attribute>
         <name>uri</name>
         <value 
xsi:type="java:java.lang.String">cocoon:/coplets/html/application</value>
      </attribute>
      <attribute>
         <name>temporary:application-uri</name>
         <value 
xsi:type="java:java.lang.String">cocoon://samples/blocks/forms/do-datasourceChooser.flow</value>

      </attribute>
   </coplet-data>
   I just point the url to a form ajax sample
   2.change portal skin files to make form render correctly.
   3.change form block datasource_chooser_template.xml,from 
   <ft:form-template action="#{$cocoon/continuation/id}.continue" 
method="POST" ajax="true">
   to
       <ft:form-template action="continue" method="POST" ajax="true" 
ajax-action="/samples/blocks/forms/continue">
      <ft:continuation-id/>
    this change will still make the sample run good.
    
    Now I run the server and enter portal block sample,it works fine only 
when finally I click "ok" button.
    If it is not a ajax form or run the form seperatly,I should see the 
result information,but now I see the form restart.
    
    I check the aceess log and add some debug code in js file,the 
flowscript did't run after
    form.showForm("datasource_chooser-display-pipeline.jx");
    and the seperate form sample will run continue twice when I click "ok" 
but only once under this condition.
    
    I guess the ajax code missing one click to make showForm complete in 
this situation,so it may be a bug.
    
    Regards
    
    Roy Huang

_________________________________________________________________
享用世界上最大的电子邮件系统― MSN Hotmail。  http://www.hotmail.com  


Mime
View raw message