cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ugo Cei <>
Subject Re: Other ID naming proposals (was Re: CForms widget ID naming)
Date Sat, 05 Nov 2005 10:20:09 GMT

Il giorno 05/nov/05, alle ore 08:46, Sylvain Wallez ha scritto:

>> So let's make other proposals. Let's consider wiget  
>> "" (e.g. a fd:field in a fd:group) and the ID of its <input>.
>> - "": the '.' is doubled, which can never conflict  
>> with a widget's full name
>> - "": generated element's name starts with a  
>> character that we can forbid as the first character of widget names
>> I prefer the first one (double '.') which is IMO more readable  
>> than the second.
> Another one, which looks more natural: "": the  
> trailing '.' ensures it cannot conflict with a widget's full name

The fact that it is not that readable might be a plus. The problem  
with double dots or a dot at the end is that it's easy to miss when  
reading the code. an extra '_' sticks out more and won't be missed as  


View raw message