cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andreas Hochsteger <>
Subject Re: Other ID naming proposals (was Re: CForms widget ID naming)
Date Sat, 05 Nov 2005 18:06:14 GMT

Sylvain Wallez wrote:
>> So let's make other proposals. Let's consider wiget "" (e.g. a 
>> fd:field in a fd:group) and the ID of its <input>.
>> - "": the '.' is doubled, which can never conflict with 
>> a widget's full name
>> - "": generated element's name starts with a character 
>> that we can forbid as the first character of widget names
>> I prefer the first one (double '.') which is IMO more readable than 
>> the second.
> Another one, which looks more natural: "": the trailing 
> '.' ensures it cannot conflict with a widget's full name
>> Other ideas?
>> Let's make a choice and have 2.1.8 out!

For me the solution with a leading '_' seems more natural, since it is 
easier to distinguish from other IDs (imagine user posts which describe 
their problems and miss the trailing '.') and it has the common semantic 
of an 'internal thing', like private variables are often named after 
(e.g. C/C++ and other languages).


View raw message