cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joerg Heinicke <>
Subject Re: Other ID naming proposals (was Re: CForms widget ID naming)
Date Sat, 05 Nov 2005 08:37:53 GMT
On 05.11.2005 08:46, Sylvain Wallez wrote:

>> So let's make other proposals. Let's consider wiget "" (e.g. a 
>> fd:field in a fd:group) and the ID of its <input>.
>> - "": the '.' is doubled, which can never conflict with 
>> a widget's full name
>> - "": generated element's name starts with a character 
>> that we can forbid as the first character of widget names
>> I prefer the first one (double '.') which is IMO more readable than 
>> the second.
> Another one, which looks more natural: "": the trailing 
> '.' ensures it cannot conflict with a widget's full name

I definitely prefer the ones which can not conflict with other widget's 
full name instead of forbidding another character. Your last proposal 
with trailing dot is the one I like most.


View raw message