cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andreas Hochsteger <>
Subject CForms widget ID naming (was Re: [Vote] Releasing on friday)
Date Thu, 03 Nov 2005 09:14:25 GMT
(I think this should be discussed in a separate thread)

Sylvain Wallez wrote:

> The last minute change is just about replacing "-input" with ":input" 
> within two XSLs, to avoid problems later.

Isn't ":" used as separator for the namespace prefix?
I don't know if this applies to IDs too, but perhaps we should 
double-check before.

If it is allowed by the XML spec, it makes me wonder, if we want to 
prefix the IDs some time in the future to use some kind of "namespace" 
here too?
Wouldn't this conflict with ":input" as you then cannot distinguish 
between the two anymore (namespace prefix vs. ":input" suffix).

Just some random thoughts ...

Perhaps it would help to write something up which summarizes all the 
IDs, names, prefixes, suffixes and namespaces involved in every part of 


View raw message