cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bruno Dumon <br...@outerthought.org>
Subject Re: Other ID naming proposals (was Re: CForms widget ID naming)
Date Sun, 06 Nov 2005 08:37:06 GMT
On Sat, 2005-11-05 at 11:20 +0100, Ugo Cei wrote:
> Il giorno 05/nov/05, alle ore 08:46, Sylvain Wallez ha scritto:
> 
> >> So let's make other proposals. Let's consider wiget  
> >> "foo.bar" (e.g. a fd:field in a fd:group) and the ID of its <input>.
> >> - "foo.bar..input": the '.' is doubled, which can never conflict  
> >> with a widget's full name
> >> - "foo.bar._input": generated element's name starts with a  
> >> character that we can forbid as the first character of widget names
> >>
> >> I prefer the first one (double '.') which is IMO more readable  
> >> than the second.
> >
> > Another one, which looks more natural: "foo.bar.input.": the  
> > trailing '.' ensures it cannot conflict with a widget's full name
> 
> The fact that it is not that readable might be a plus. The problem  
> with double dots or a dot at the end is that it's easy to miss when  
> reading the code. an extra '_' sticks out more and won't be missed as  
> easily.

agreed, +1 for the underscore

-- 
Bruno Dumon                             http://outerthought.org/
Outerthought - Open Source, Java & XML Competence Support Center
bruno@outerthought.org                          bruno@apache.org


Mime
View raw message