cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marc Portier <...@outerthought.org>
Subject Re: [RT] flow machinery
Date Thu, 27 Oct 2005 08:59:44 GMT


Vadim Gritsenko wrote:
> Torsten Curdt wrote:
> 
>> IMHO having map:act *and* map:call is not really nice.
> 
> 
> Why not? IMHO it is more readable to have
> 
>   <map:act function="foo"/>
>   <map:call function="bar"/>
> 
> than:
> 
>>   <map:call action="my-action" function="function-name"/>
>>   <map:call flow="my-flow" function="start-of-flow"/>
> 
> 
> I'd rather rename <map:call/> to something more flow-specific (e.g.
> <map:invoke/>) than <map:act/> to <map:call/>.
> 

+1, agree

> Another reason for clear separation of these two concepts is that
> <map:call function=""/> requires to sendPage(), while action does not.
> 

I think this part is what I hinted at in my other post about
historically actions being something in-between
flowlike-decission-takers and custom input-modules...

so what we talk about here and now are probably not actions as we know
them ?

-marc=
-- 
Marc Portier                            http://outerthought.org/
Outerthought - Open Source, Java & XML Competence Support Center
Read my weblog at                http://blogs.cocoondev.org/mpo/
mpo@outerthought.org                              mpo@apache.org

Mime
View raw message