cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vadim Gritsenko <va...@reverycodes.com>
Subject Re: [RT] flow machinery
Date Wed, 26 Oct 2005 21:47:51 GMT
Torsten Curdt wrote:
> IMHO having map:act *and* map:call is not really nice.

Why not? IMHO it is more readable to have

   <map:act function="foo"/>
   <map:call function="bar"/>

than:

>   <map:call action="my-action" function="function-name"/>
>   <map:call flow="my-flow" function="start-of-flow"/>

I'd rather rename <map:call/> to something more flow-specific (e.g. 
<map:invoke/>) than <map:act/> to <map:call/>.

Another reason for clear separation of these two concepts is that <map:call 
function=""/> requires to sendPage(), while action does not.

Vadim

Mime
View raw message