cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Antonio Gallardo <agalla...@agssa.net>
Subject Re: [cforms] rethinking library naming
Date Sun, 02 Oct 2005 02:49:34 GMT
Sylvain Wallez wrote:

> Ugo Cei wrote:
>
>> Il giorno 26/set/05, alle 17:23, Sylvain Wallez ha scritto:
>>
>>> - rename <fd:class> to <fd:macro> (this is the wording used on the

>>> wiki [1][2])
>>> - rename <fd:new> to <fd:expand>: "expanding" is the word used 
>>> traditionally to denote insertion of the macro contents at the 
>>> current location.
>>
>>
>>
>> I'd rather use <fd:call-macro> or something like that to reinforce 
>> the idea that what we are expanding is indeed a macro.
>
>
>
> Hmm... call-macro implies some kind of statement execution, while we 
> are just expanding the contents of the macro...

Yes. What about <fd:expand-macro>, <fd:apply-macro> or <fd:use-macro>?

Best Regards,

Antonio Gallardo.

>
> Sylvain
>


Mime
View raw message