cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Berin Loritsch <blorit...@d-haven.org>
Subject Re: forms block does not compile for java 1.3
Date Thu, 29 Sep 2005 13:44:46 GMT
Antonio Gallardo wrote:

> Ralph Goers wrote:
>
>> I guess this means forms trunk has to support JDK 1.3 and cannot move 
>> to 1.4?
>
>
> Yep, since we are now sharing the same form block (in cocoon-blocks) 
> for both cocoon versions (2.1.x and 2.2).
> Seems like every day JDK 1.3 compatibility becomes a bigger PITA! :-( 
> Need we still care?
>

In the case of the RuntimeExceptions, if we have our own exception class 
that extends RuntimeException and supports the necessary constructor we 
effectively accomplish two things:

1) We can support any version of Java
2) We have a much better clue of where the runtime exception came 
from--it is essentially branded.


Mime
View raw message