cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sylvain Wallez <sylv...@apache.org>
Subject Re: forms block does not compile for java 1.3
Date Thu, 29 Sep 2005 06:38:25 GMT
Antonio Gallardo wrote:

> Ralph Goers wrote:
>
>> I guess this means forms trunk has to support JDK 1.3 and cannot move 
>> to 1.4?
>
>
> Yep, since we are now sharing the same form block (in cocoon-blocks) 
> for both cocoon versions (2.1.x and 2.2).


FYI, the goal has always been to have the same sources in both cforms 
branches. Having two branches led people to modify one or the other, not 
always porting changes. I was tired of doing the merge again and again, 
and I spent more than one full day merging 2.1, 2.2 and the library 
branches. That's why I decided to use svn:external, to save merging time.

Now for sure this comes with the constraint of being 2.1.x compatible, 
both in terms of code (there are some nifty Rhino 1.5 features that I 
can't use) and JDK level (thanks to commons-lang, this is easy)

> Seems like every day JDK 1.3 compatibility becomes a bigger PITA! :-( 
> Need we still care?


Well, yes. And thanks for being our "Mr JDK 1.3 compatibility" :-)

Fixed, please cross-check!

Sylvain

-- 
Sylvain Wallez                        Anyware Technologies
http://people.apache.org/~sylvain     http://www.anyware-tech.com
Apache Software Foundation Member     Research & Technology Director


Mime
View raw message