cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Reinhard Poetz <>
Subject Re: forms block does not compile for java 1.3
Date Thu, 29 Sep 2005 05:25:34 GMT
Antonio Gallardo wrote:
> Ralph Goers wrote:
>> I guess this means forms trunk has to support JDK 1.3 and cannot move 
>> to 1.4?
> Yep, since we are now sharing the same form block (in cocoon-blocks) for 
> both cocoon versions (2.1.x and 2.2).
> Seems like every day JDK 1.3 compatibility becomes a bigger PITA! :-( 
> Need we still care?

yes, as discussed twenty times or so, we can't change the minimum JDK version 
for 2.1.x as it's only a patch level release. As 2.1.8 will be our last 2.1.X 
release, the days of JDK1.3 and the PITA of maintaining two branches are counted 
though :-)

Reinhard Pötz           Independent Consultant, Trainer & (IT)-Coach 

{Software Engineering, Open Source, Web Applications, Apache Cocoon}


View raw message