cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joerg Heinicke <joerg.heini...@gmx.de>
Subject Re: forms block does not compile for java 1.3
Date Thu, 29 Sep 2005 05:24:28 GMT
On 29.09.2005 06:16, Antonio Gallardo wrote:

>> I guess this means forms trunk has to support JDK 1.3 and cannot move 
>> to 1.4?
> 
> Yep, since we are now sharing the same form block (in cocoon-blocks) for 
> both cocoon versions (2.1.x and 2.2).
> Seems like every day JDK 1.3 compatibility becomes a bigger PITA! :-( 
> Need we still care?

Please don't let this discussion arise on every incompatibility we have, 
it's getting boring.

1. 2.1.x *is* actually our latest release and not a future 2.2.
2. 2.1.x supports JDK 1.3.
3. We have to care about it as long as 2.1 is maintained - this does not 
stop with the first 2.2 release.

If now the forms block and others are shared between 2.1 and trunk we 
must keep JDK 1.3 compatibility. If we don't want that we must provide a 
2.1 and trunk version of the blocks. But I guess at the moment it is 
easier to get this fixed instead of maintaining a block twice.

Jörg

Mime
View raw message