cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From hepabolu <>
Subject Re: [cforms] rethinking library naming
Date Mon, 26 Sep 2005 16:30:37 GMT
I haven't looked at the new and improved CForms yet, but I'm all for 

Sylvain Wallez wrote:

> These names make it very difficult to understand what does what. I'd 
> like therefore to propose a renaming:
> - rename <fd:class> to <fd:macro> (this is the wording used on the wiki 
> [1][2])

What about the jxmacros? Doesn't that lead to confusion? I know 
namespace is different, but that is easily lost when scanning quickly 
through the file.

> - rename <fd:new> to <fd:expand>: "expanding" is the word used 
> traditionally to denote insertion of the macro contents at the current 
> location.

"expand" does fit better with "macro", but I'm having doubts about 
"macro" and to me "new" fits better with "class"

> - rename <fd:import> to <fd:load-library>, to clearly indicate that 
> widgets in the library are made available but not inserted right now, in 


> contrast with <jx:import> in JXTG that executes the imported template.
> - rename <fd:expand> to <fd:insert> (or <fd:use>?)
> For this last item, it has to be noted that it is equivalent to an 
> "untyped extension", i.e.
>    <fd:insert ref="lib:myfield"/>
> is equivalent to
>    <fd:field extends="lib:myfield"/>
> if of course "myfield" is a field.

Well, if both are equal, I'm all for the last (i.e. field extends 
library field).

> Also, I think we should allow <fd:load-library> only as first-level 
> children of <fd:form> and <fd:library>, as it doesn't really make sense 


Bye, Helma

View raw message