cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Antonio Gallardo <agalla...@agssa.net>
Subject Re: Extremely odd source in XSPs (breaks build)
Date Mon, 05 Sep 2005 00:23:52 GMT
Pier Fumagalli wrote:

> On 5 Sep 2005, at 00:15, Antonio Gallardo wrote:
>
>> Hi Pier,
>>
>> Please read: http://marc.theaimsgroup.com/?l=xml-cocoon- 
>> dev&m=112586325420497 ;-)
>
>
> Yep, that brings to a point... Who in the world did put that  
> character there in the very first place? I mean, not everyone uses  
> ISO8859-1 as its encoding, more and more people are moving to UTF-8  
> nowadays (read -me- :-) :-)
>
> I'm seeing LOTSA characters from Latin-1 in the source code <http:// 
> www.unicode.org/charts/PDF/U0080.pdf> (especially in people's names!)

You wanna see name? Then use "svn log [src-path]" or "svn blame 
[src-path]" ;-)

For sure, it is not me, I use UTF-8:

$locale
LANG=es_NI.UTF-8
LC_CTYPE="es_NI.UTF-8"
LC_NUMERIC="es_NI.UTF-8"
LC_TIME="es_NI.UTF-8"
LC_COLLATE="es_NI.UTF-8"
LC_MONETARY="es_NI.UTF-8"
LC_MESSAGES="es_NI.UTF-8"
LC_PAPER="es_NI.UTF-8"
LC_NAME="es_NI.UTF-8"
LC_ADDRESS="es_NI.UTF-8"
LC_TELEPHONE="es_NI.UTF-8"
LC_MEASUREMENT="es_NI.UTF-8"
LC_IDENTIFICATION="es_NI.UTF-8"
LC_ALL=

>
> We should make sure that whenever code is written, any character  
> outside the "Basic-Latin" Unicode spec <http://www.unicode.org/charts/ 
> PDF/U0000.pdf> is correctly encoded as \uXXXX, otherwise things are  
> going to start breaking... :-D


+1 and this is why I sent my first mail related to this issue:

http://marc.theaimsgroup.com/?l=xml-cocoon-dev&m=112586325420497

Best Regards,

Antonio Gallardo


Mime
View raw message