cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Upayavira ...@odoko.co.uk>
Subject Re: [2.2] Using includes in the sitemap for components?
Date Sun, 04 Sep 2005 16:39:16 GMT
Niclas Hedhman wrote:
> On Sunday 04 September 2005 23:10, Carsten Ziegeler wrote:
> 
>>Hmm, for a) I more and more think we should move the whole ECM++ stuff
>>from 2.2
>>to 2.1.x (readd the support for Composable and Instrumentable) and be
>>able to use
>>all the nice little things from 2.2 *today*
> 
> 
> That sounds more like it is time for 2.1.x to become 2.2 and the HEAD targets 
> a 2.3, or even a 3.0, with real-blocks.
> 
> Dewey to me has always meant that a new "feature" increases the second digit, 
> but the 2.1.x line have seen all kinds of new features being added.
> 
> What's the scare to use up more numbers??

I couldn't agree more. Personally I'd be -1 on porting ECM++ back to 
2.1.x. 2.1.x should be a _maintenance_ branch, and unless we can focus 
on getting 2.2 out in some form, we risk some serious geopardy for our 
community, I think.

So, let's release 2.2, make that the main branch, and start adding OSGi, 
Maven, etc, into 2.3.

With Carsten's proposal to release every two months, we're almost back 
into release early, release often, but, problem is, we'd be releasing a 
branch often, which is seriously broken, IMO.

I'd say, let's release 2.2M1 at the same time as 2.1.8, say, just after 
the GetTogether.

Regards, Upayavira

Mime
View raw message