cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Antonio Gallardo <agalla...@agssa.net>
Subject Saxon and cforms revisited
Date Sat, 03 Sep 2005 03:25:24 GMT
Hi:

I just wanted to do a test drive with saxon 8.5.1.  I configured saxon 
in the current branch 2.1.8-dev (r267217 - 2005-09-02 09:54:23) . The 
system is able to process pages, when there is no cforms code inside. I 
was unable to see a simple cforms working. :-(

I need to said that the whole system works perfectly with xalan. No 
errors at all. But with saxon it fails!

The interesting thing is that saxon works without problems here:

<map:match pattern="test-a">
        <map:generate type="file" src="a.xml"/>
       <map:transform type="xslt" src="object.xsl" />
    <map:serialize/>
 </map:match>

Note, I saved the a.xml from the output of the original pipeline:

<map:match pattern="test-original">
        <map:generate type="jx" src="pattern.xml">
          <map:parameter name="a" value="1"/>
          <map:parameter name="b" value="2"/>
    </map:generate>
    <map:transform type="xinclude"/>
    <!-- Here I placed a xml serializer to get the a.xml file -->
    <map:transform type="xslt" src="object.xsl" />
    <map:serialize/>
 </map:match>

This pipeline fails with message:

net.sf.saxon.trans.DynamicError: Cannot output a namespace node for the 
default namespace when the element is in no namespace

In the xslt page the offending code is the last template matcher:

    <xsl:template match="@*|node()" priority="-1">
        <xsl:copy>
            <xsl:apply-templates select="@*|node()"/>
        </xsl:copy>
    </xsl:template>

Somebody already met a similar trouble?

Best Regards,

Antonio Gallardo.

Mime
View raw message