cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Stevens" <>
Subject Re: CoWarp (was Re: svn commit: r232855...)
Date Wed, 17 Aug 2005 09:22:22 GMT
Although as a mere user my vote probably doesn't count, from my perspective 
I'm extremely grateful that Cocoon still supports 1.3 and hope that remains 
the case for the 2.1.x releases.  Our production servers are running 
Websphere 5.0.x, which only has JDK 1.3.1, and aren't likely to upgrade in 
the short term (a combination of internal bureaucracy and the amount of 
testing involved for all the other apps running on those servers).  So if 
2.1.8 drops support for 1.3, I'll probably have to stick at 2.1.7 for our 
team's app; either that or drop Cocoon altogether and migrate to the 
"company standard" (proprietary) framework, which I've managed to hold out 
against up till now ;-)

Besides, wouldn't something like that justify a bigger change in version 
number i.e. if you're going to drop it, do it in 2.2?  Also, when you do 
drop the 1.3 support, why not drop the servlet 2.2 support as well and start 
using standard HttpRequest/ReponseWrappers in the JSP block instead of your 
own version?  I'd have thought any app server that supports 1.4+ would also 
support servlet 2.3+.  Plus, I've already had to write a custom JSPEngine 
implementation because Websphere won't do includes if the request isn't the 
standard wrapper class...


>From: Vadim Gritsenko <>
>Subject: Re: CoWarp (was Re: svn commit: r232855...)
>Date: Tue, 16 Aug 2005 23:27:30 -0400
>Antonio Gallardo wrote:
>>If ..., I will like to propose for the next cocoon 2.1.x release to set 
>>the monimal JVM requirement to 1.4.
>>Can I start a vote about moving to 1.4?
>-1 for change of JVM requirement in the 2.1.8 release, which should be 
>released ASAP anyway - it is delayed too much already.
>+1 for the change in any release after 2.1.8.

View raw message