cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joerg Heinicke <joerg.heini...@gmx.de>
Subject snapshot releases (was: target release 1.3 conflicts with default source release 1.5 (on daily snapshot))
Date Thu, 04 Aug 2005 20:35:24 GMT
On 04.08.2005 22:20, Joerg Heinicke wrote:

>> Compiling 268 source files to 
>> /export/home/ray/cocoon-2.1/build/cocoon-2.2.0-dev/blocks/forms/dest
>> /export/home/ray/cocoon-2.1/src/blocks/forms/java/org/apache/cocoon/forms/event/ProcessingPhase.java:22:

>> as of release 1.5, 'enum' is a keyword, and may not be used as an 
>> identifier
>> (try -source 1.4 or lower to use 'enum' as an identifier)
>> import org.apache.commons.lang.enum.ValuedEnum;
>>                               ^
>> -- 
>>
>> so I stopped to ask "If the java source in the snapshot does not 
>> compile / has never been changed, is it the incorrect source?"   
>> Should I get bleeding-edge cocoon from somewhere else?
> 
> 
> It seems to be indeed the wrong source. The code has been changed in 
> October last year (!!) to be Java 5 compatible:
> import org.apache.commons.lang.enums.ValuedEnum;
> Try to get Cocoon from SVN if the snapshots don't work. I will have a 
> look why.

Could it be that the daily snapshots are still built from CVS? If it is 
not possible to switch to SVN we should stop building that snapshots to 
avoid confusion.

Joerg

Mime
View raw message