cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Carsten Ziegeler <>
Subject Re: DO NOT REPLY [Bug 35521] - [PATCH] NEW - a NullSource component
Date Fri, 29 Jul 2005 07:21:37 GMT
Sylvain Wallez wrote:
> Vadim Gritsenko wrote:

>>IMHO, wording "create-document" implies that (probably persistent) 
>>document is being created somewhere, which is then fed into the pipeline.
>>"null", on the other hand, is closer to the meaning of what source 
>>actually does. If "null" seems inappropriate, it can be named "empty", 
>>which imho is the best name for it:
>>   empty:
>>   empty:root-element
> +1. "empty" is clearer about this source's intent.
Actually I don't really care what we name it, although I think that a
that has a root element is not really empty :) But let's not argue about
if you think that 'empty' is a better name, just go ahead a change it.


Carsten Ziegeler - Open Source Group, S&N AG

View raw message