cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Lowe <mel...@gmail.com>
Subject Re: [websphere6] deploying cocoon servlet in websphere fails (2)
Date Fri, 29 Jul 2005 19:02:00 GMT
I've tried everything with 2.1.6, webspere 5.1, the only thing I've
had working on a local version of websphere is when i add all the
classes to the server classpath. Not even ws.libs digs..

Setting the PARENT_LAST and both scoping the calssloader to module and
application, the problem was related to the rhino jar not being
loaded.. So after noticing that websphere has a js lib, i swapped it
for the cocoon version (just to make sure), and still gave me an error
about not finding the rhino stuff.

Sorry I cant be of any help, but at least you've got some company :)

Mark

On 7/23/05, Kees Broenink <kees.broenink@backbase.com> wrote:
> Forgot to mention that using the ParanoidCocoonServlet or the web.xml
> setting 'init-classloader' did not solve the problem.
> 
> I am using Cocoon 2.1.7 with two blocks:
> - include.block.jsp=true
> - include.block.paranoid=true
> 
> With ParanoidServlet the error is different:
> 
> java.lang.ExceptionInInitializerError
>         at
> org.apache.cocoon.components.store.impl.EHDefaultStore.initialize(EHDefa
> ultStore.java:213)
>         at
> org.apache.avalon.framework.container.ContainerUtil.initialize(Container
> Util.java:283)
>         at
> org.apache.avalon.excalibur.component.DefaultComponentFactory.newInstanc
> e(DefaultComponentFactory.java:277)
> 
> Anybody?
> 
> Kees
> 
> -----Oorspronkelijk bericht-----
> Van: Kees Broenink [mailto:kees.broenink@backbase.com]
> Verzonden: Friday, July 22, 2005 4:17 PM
> Aan: dev@cocoon.apache.org; users@cocoon.apache.org
> Onderwerp: [websphere6] deploying cocoon servlet in websphere fails
> 
> 
> Hi lists,
> 
> I am using Cocoon for a long time now, also building my own transformers
> etc. But I always used Tomcat to deploy the servlet. I have successfully
> used Weblogic (configuring my hand using a exploded war). But now I have
> problems with Websphere 6. I have applied the helpful interformation in
> the archives about setting PARENT_LAST as Classloader Mode. I also set
> the WAR classloader policy from Module to Application.
> 
> The error I get is:
> 
> java.lang.NoClassDefFoundError: net/sf/ehcache/CacheManager
>         at
> org.apache.cocoon.components.store.impl.EHDefaultStore.initialize(EHDefa
> ultStore.java:213)
>         at
> org.apache.avalon.framework.container.ContainerUtil.initialize(Container
> Util.java:283)
>         at
> org.apache.avalon.excalibur.component.DefaultComponentFactory.newInstanc
> e(DefaultComponentFactory.java:277)
>       ....
> 
> Any help very much appreciated.
> 
> Kees
> 
> 
>

Mime
View raw message