cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Niclas Hedhman <nic...@hedhman.org>
Subject Re: [osgi] metadata
Date Mon, 04 Jul 2005 11:14:34 GMT
On Monday 04 July 2005 17:25, Reinhard Poetz wrote:
> I'm a bit confused about the relation between import/export package and
> Require-Bundle. Does anybody know about this?

Is this R4 or Eclipse? I can't find it in R3 spec.

By the sound of it, "Require-Bundle X" means that the bundle will not be 
started without the "X Bundle" being present. A kind of "Must Have" 
dependency. And the import is the "normal" "Would Like To Have" dependency, 
understood implicitly that the bundle will work without it (work being fairly 
loose description).


Cheers
Niclas

Mime
View raw message