cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kees Broenink" <kees.broen...@backbase.com>
Subject SOLVED: [websphere6] deploying cocoon servlet in websphere fails (2)
Date Sat, 23 Jul 2005 20:24:41 GMT
Dear Cocoon lovers,

Sorry for the polution on the lists about Websphere. I have solved the
problems.
I forgot to clean the Websphere cache (in various temp and wstemp
directories) when I changed the settings.
I must say that the Wiki info is not that clear. The following works for
me:

Most important is to add a file to your classes directory called
commons-logging.properties. It contains one line:
org.apache.commons.logging.Logfactory=org.apache.commons.logging.impl.Lo
gFactoryImpl

Funny hey. Let's solve this in Cocoon 2.1.8. 

There is no need for ParanoidCocoonServlet or setting init-classloader
to true.

Use Websphere console http://localhost:9060/ibm/console
- on the left click on + Applications
- click on Enterprise Applications
- on the right click on your application
- set Class Loader mode to PARENT_LAST
- set WAR class loader policy to APPLICATION

That's it.

Kees


Mime
View raw message